Indicator lights on 2011 WK - Jeep Forum - Forums and Owners Club
Jeep Forum - Forums and Owners Club

Go Back   Jeep Forum - Forums and Owners Club > Jeep Forum Help Zone - Jeep Problems, Complaints, and Solutions! > Electrical Problems and Questions


Notices

Reply
 
Thread Tools
  #1  
Old 06-05-2017, 03:30 PM
Hogwild11 Hogwild11 is offline
Jeep Forum Newcomer
 
Join Date: Jun 2017
Gender: Male
Model and Year: Grand Cherokee Overland 2011
Color: White
Posts: 1
Hogwild11 is on a distinguished road
Post Indicator lights on 2011 WK

I have a 2011 Grand Cherokee Overland which has been behaving as expected. However, a couple of days ago I'm traveling at highway speed and three indicator lights illuminate (with audibles) on my cluster. They are the Electronic Stability Control (ESC), the SERV 4WD, and the 4WD LOW indicator lights. No, I'm not in 4-wheel drive and there has been no impact to driving ability. This seems to be some sort of software glitch and perhaps a bad sensor. Any comments/suggestions?
__________________
JeepForumz.com | Jeep Forum | Jeep Forums | Jeep Performance | Jeep Accessories
Reply With Quote
Sponsored links
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


» Advertisement







All times are GMT -5. The time now is 01:04 PM.


Powered by vBulletin® Version 3.8.10 Beta 2
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
vB.Sponsors
Copyright JeepForumZ.comAd Management by RedTyger